P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Also including Oldsmobile, Geo, Hummer, and Saturn (North American brands)
cedricleeward
Posts: 1
Joined: Fri Nov 20, 2015 3:00 pm

P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Postby cedricleeward » Fri Nov 20, 2015 3:23 pm

2008 LTZ Chevy Suburban 4WD, FLEX- 5.3
I use top tier detergent (supreme). About a month ago my check engine light came on and it spit out codes P0175/P0172, so I go and change the Purge Solenoid, I believe it was Bank 1, the easier one to get to. Scanner is still spitting out P0175/P0172. I then check my gas cap, make sure it was properly sealed, no luck there. So next I go and change the Vapor Canister and Vent Solenoid Valve Hose. I disconnect the negative terminal and reset the engine light, all is good for 2 months. Then last week I get codes P0172 :D /P0496- system too lean. I check the hose running to the Purge Solenoid and any rips in the Solenoid Valve Hose running under my truck. I am thinking of checking, Mass Air Flow Sensor, clean then replace? tune-up(change spark plugs)? New Air filter?
I have already tried cleaning the fuel system with additive to the fuel tank, the engine light went off for about five days then returned. I am in no way a mechanic, I watch Youtube videos to keep my cars running good. I also have a '72 Chevelle I play with :wink: . ANY HELP WOULD BE MUCH APPRECIATED... THANKS!


kev2
Posts: 6578
Joined: Sat Aug 29, 2009 4:24 pm

Re: P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Postby kev2 » Fri Nov 20, 2015 4:13 pm

DTC P0172 Fuel Trim System Rich Bank 1
DTC P0175 Fuel Trim System Rich Bank 2
Explain why you did purge valve?

DTC P0496 Evaporative Emission (EVAP) System Flow During Non-Purge -
this is a purge issue- easy check be sure no vacuum past purge valve ....work this first before rich codes..

first you should not need supreme,
be sure not to top off after pump kicks off once. it can affect purge valve that's why.

tell us vehicle is STOCK no aftermarket BS...

autojoe
Posts: 721
Joined: Fri Apr 12, 2013 8:23 am

Re: P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Postby autojoe » Sat Nov 21, 2015 8:27 am

Purge Solenoid, I believe it was Bank 1......you changed purge solenoid or 02 sensor?

Konakevin
Posts: 1
Joined: Fri Dec 11, 2015 8:35 am

Re: P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Postby Konakevin » Fri Dec 11, 2015 8:43 am

Cedric, Did you ever figure this out? I have the same thing going on... P0496/P0175/P0172

I also use Super Unleaded (Should I not?)
I also have topped off the tank (Is this bad?)
I also have filled up the tank while the motor was running (Could this cause the P0496?)

Thanks in advance for any help.

kev2
Posts: 6578
Joined: Sat Aug 29, 2009 4:24 pm

Re: P0175/P0172/P0496 -- 2008 LTZ Chevy Suburban 4WD, FLEX- 5.3

Postby kev2 » Fri Dec 11, 2015 9:27 am

I also use Super Unleaded (Should I not?) unnecessary- and expensive $$$
I also have topped off the tank (Is this bad?) do not after pump kicks off.
I also have filled up the tank while the motor was running - do not do it.

Could this cause the P0496? topping off- overfilling may cause.

SWAG do you use a K&N type filter?


Return to “GM: Chevrolet, GMC, Buick, Cadillac”



Who is online

Users browsing this forum: No registered users and 0 guests